In un intervallo filtrato di Excel abbiamo bisogno di sommare tutte le celle comprese tra due criteri, ad esempio contare tutte le celle maggiori di 10 e contemporaneamente minori di 20 in una tabella cui abbiamo applicato filtri sulle colonne.

Possiamo utilizzare la formula seguente:

=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(A2:A1000;RIF.RIGA(A2:A1000)-MIN(RIF.RIGA(A2:A1000));;1))*(A2:A1000>10)*(A2:A1000<20))

Dove
A2:A1000 è l’intervallo che contiene le celle da sommare
>10 e <20 sono i due criteri

Filtrando la tabella tramite il filtro automatico la somma verrà effettuata solo sulle celle visibili.

Microsoft Excel: sommare in un intervallo filtrato celle comprese tra due criteri e con parte di una cella corrispondente ad un testo
In attesa del Parsenn Derby

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »