Immaginiamo di avere la necessità di dover contare il numero di specifici caratteri nelle celle di Excel ovvero quante volte un carattere è presente in una cella di Excel o in un intervallo di celle di Excel.

Ecco come fare:

Contare quante volte un carattere è presente in una cella
La cella A1 contiene il testo AAXBX, vogliamo sapere quante volte è presente il carattere X

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la formula seguente:

=LUNGHEZZA(A1)-LUNGHEZZA(SOSTITUISCI(A1;"X";""))

Contare quante volte un carattere è presente in un intervallo di celle
La cella A1 contiene il testo AAXBX e la cella A2  contiene il testo BBXAXXB, vogliamo sapere quante volte è presente il carattere X nell’intervallo A1:A2

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la formula seguente, inserendola in formato matrice ovvero confermando l’inserimento con CTRL+MAIUSC+INVIO:

=SOMMA(LUNGHEZZA(A1:A2)-LUNGHEZZA(SOSTITUISCI(A1:A2;"X";"")))

Se invece ti serve contare le occorrenze delle singole parole presenti in una cella o in un intervallo Excel puoi seguire le istruzioni che troverai cliccando qui.

Abilitazione parallela alla professione per futuri docenti di scuola media e media superiore
Manuale Windows Server 2012

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »