Come fare per evidenziare in una colonna o in una riga di Excel i dati ripetuti?

Immaginiamo di avere lungo una colonna o una riga una serie di numeri casuali e di voler far si che tutte le celle che contengono valori che appaiono più di una volta vengano colorate in rosso.
Dovremo ricorrere alla formattazione condizionale in cui la condizione è la formula CONTA.SE


La situazione di partenza è la seguente:

Ciò che vogliamo ottenere è che tutti i numeri ripetuti vengano evidenziati con un colore, ad esempio rosso.

In Excel XP/2003
Posizionarsi sulla cella B3 e attivare la finestra della Formattazione Condizionale tramite il menù Formato -> Formattazione Condizionale, scegliendo la formula è come condizione e come parametro la funzione =CONTA.SE(B:B;B3)>1
Assegnare quindi tramite il pulsante Formato… la formattazione desiderata per le celle ripetute.

Cliccare quindi su ok; se il numero contenuto all’interno della cella B3 è presente altre volte nella colonna B, la cella stessa prenderà la formattazione che abbiamo assegnato nella finestra della Formattazione Condizionale.
A questo punto copiare la cella B3 e tramite Incolla Speciale incollare il formato in tutte le celle dell’elenco.

In Excel 2007
Posizionarsi sulla cella B3 e attivare la finestra della Formattazione Condizionale tramite la Scheda Home -> Gruppo Stili -> Pulsante Formattazione Condizionale -> Comando Nuova regola
Selezionare la regola Utilizza una formula per determinare le celle da formattare e inserire
la funzione =CONTA.SE(B:B;B3)>1
Assegnare quindi tramite il pulsante Formato… la formattazione desiderata per le celle ripetute.

Cliccare quindi su ok; se il numero contenuto all’interno della cella B3 è presente altre volte nella colonna B, la cella stessa prenderà la formattazione che abbiamo assegnato nella finestra della Formattazione Condizionale.
A questo punto copiare la cella B3 e tramite Incolla Speciale incollare il formato in tutte le celle dell’elenco.

Il risultato finale è il seguente:



N.B.: nella formula =CONTA.SE(B:B;B3)>1 l’intervallo B:B rappresenta tutta la colonna ma può essere sostituito con la selezione delle sole celle da analizzare o con il nome del gruppo di celle.
Lo stesso discorso vale anche se i dati da prendere in considerazione non sono lungo la colonna ma lungo la riga.

N.B.2: In Excel 2007 in realtà ciò che si è detto sopra è automatico in quanto la Formattazione Automatica prevede già la possibilità di evidenziare i valori duplicati.
Basterà selezionare l’intervallo che contiene i dati duplicati quindi scegliere la Scheda Home -> Gruppo Stili -> Pulsante Formattazione Condizionale -> Regole evidenziazione celle -> Valori duplicati



In questa finestra di dialogo basterà scegliere il tipo di formattazione che si vuole applicare alle celle che contengono i valori duplicati.

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »