Abbiamo la necessità di dover contare le occorrenze di specifiche parole nelle celle di Excel ovvero quante volte una parola è presente all’interno in una cella di Excel o in un intervallo di celle di Excel.

Ecco come fare:

Contare le occorrenze di una specifica parola in una cella Excel
La cella A1 contiene il seguente testo: Andrea, Paolo, Monica, Luca, Andrea

Abbiamo bisogno di sapere quante volte è presente la parola Andrea nella cella A1

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la funzione seguente:

=(LUNGHEZZA(A1)-LUNGHEZZA(SOSTITUISCI(MINUSC(A1);"andrea";"")))/LUNGHEZZA("andrea")

Contare le occorrenze di una specifica parola in un intervallo di celle Excel
Ipotizziamo di voler contare quante volte la parola Andrea è contenuta nelle celle dell’intervallo A1:A100

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la funzione seguente, inserendola in formato matrice ovvero confermando l’inserimento con CTRL+MAIUSC+INVIO:

=SOMMA((LUNGHEZZA(A1:A100)-LUNGHEZZA(SOSTITUISCI(MINUSC(A1:A100);"andrea";"")))/LUNGHEZZA("andrea"))

N.B: la funzione non fa distinzione tra maiuscole e minuscole e per questo motivo devi inserire, nella funzione, il termine di ricerca in minuscolo.

Se invece la parola da cercare è contenuta solo una volta nella singola cella Excel e vuoi sapere quante celle in totale la contengono, la funzione che dovrai usare è la seguente:

=CONTA.SE(A1:A100;”*andrea*”)

Infine, se ti serve contare il numero di specifici caratteri presenti in una cella o in un intervallo Excel puoi seguire le istruzioni che troverai cliccando qui.

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »