Immaginiamo di avere la necessità di dover contare il numero di occorrenze di specifici numeri in una formula di Excel ovvero quante volte un numero è presente in una formula inserita in una cella di Excel.

Ecco come fare:

Contare quante volte un numero è presente in una formula in una cella di Excel
La cella A1 contiene ad esempio la formula =3*2+4+5*3, vogliamo sapere quante volte è presente il numero 3

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la formula seguente:

=LUNGHEZZA(TESTO.FORMULA(A1))-LUNGHEZZA(SOSTITUISCI(TESTO.FORMULA(A1);3;""))

Contare quante volte un numero è presente nelle formule di un intervallo di celle
La cella A1 contiene ad esempio la formula =3*2+4+5*3 e la cella A2  contiene ad esempio la formula =3+4+2*5, vogliamo sapere quante volte è presente il numero 3 nell’intervallo A1:A2

Nella cella in cui si desidera venga visualizzato il risultato dovremo utilizzare la formula seguente, inserendola in formato matrice ovvero confermando l’inserimento con CTRL+MAIUSC+INVIO:

=SOMMA(LUNGHEZZA(TESTO.FORMULA(A1:A2))-LUNGHEZZA(SOSTITUISCI(TESTO.FORMULA(A1:A2);3;"")))

Se invece ti serve contare le occorrenze di singoli caratteri presenti in una cella o in un intervallo Excel puoi seguire le istruzioni che troverai cliccando qui.

Informatics teacher, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »