Immaginiamo di aver bisogno, nell’esempio precedente, di dover sommare i valori di tutte le voci che contengono nella colonna prodotto il nome Rosso con valore maggiore di 1 e minore di 6 filtrando secondo il nome Pippo.

La formula inserita nella cella G4 risulterà essere la seguente:

=MATR.SOMMA.PRODOTTO(--(VAL.NUMERO(TROVA(F10;$B$2:$B$6)));
SUBTOTALE(9;SCARTO($C$2:$C$6;RIF.RIGA($C$2:$C$6)
-MIN(RIF.RIGA($C$2:$C$6));;1))*($C$2:$C$6>1)*($C$2:$C$6<6))

Il risultato finale è visibile nella tabella seguente:

Parsenn Derby Davos e Atomic Speed Challenge 2013
Microsoft Excel: sommare in un intervallo filtrato celle comprese tra due criteri

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »