Nella media ponderata o media pesata, a differenza della media aritmetica, ogni numero ha un suo peso che influisce sul calcolo finale. Immaginiamo ad esempio di dover calcolare la media pesata di una serie di voti che però hanno importanze differenti.

La media è data dalla somma dei voti diviso il numero dei voti stessi, ovvero (8+10+5+6)/4

La media ponderata è invece la somma dei prodotti tra voto e peso diviso per la somma dei pesi ovvero (8*4+10*2+5*3+6*5)/(4+2+3+5)

In pratica in Excel le funzioni da utilizzare sono:

per la media: =MEDIA(B2:B5)

per la media ponderata: =MATR.SOMMA.PRODOTTO(B2:B5;C2:C5)/SOMMA(C2:C5)

Se invece dovessimo calcolare la media ponderata per tutti i voti il cui peso è maggiore di 3 dovremmo modificare la funzione precedente in modo tale da considerare solo i valori che interessano; nel caso specifico la funzione diventerebbe:

=MATR.SOMMA.PRODOTTO(--(C2:C5>3);B2:B5;C2:C5)/SOMMA.SE(C2:C5;">3";C2:C5)

in cui in MATR.SOMMA.PRODOTTO è stato aggiunto un primo argomento che permette di filtrare i dati e la SOMMA è stata sostituita dalla funzione SOMMA.SE(intervallo di riferimento;criterio;effettive celle da sommare) tramite la quale la somma viene effettuata solo sulle celle che ci interessano.

Informatics, ski racer, loves Finland, Norway, mountains, squash, photography, Drones and RC Helicopter – Snapchat: andrea.perotti

Translate »